[RESOLVED] Elite Force stock game issues for graphic overhaul mod

Started by don_quichote, May 28, 2017, 08:50:10 AM

Previous topic - Next topic


Hi guys, I am going to release my overhaul modification for Star Trek Voyager Elite Force.


But I am still facing some issues :chin: . Coding the RPG-X standalone version needs in deed a lot of knowledge about the game´s architecture, that's why I will write my problems and here let's see if there is somebody who could help. To clear it out: that's about the stock game. ^_^

1. When in 1920x1080 display resolution mode I don't see the intro videos, It's just a white wall. The sequences between the episodes during the story mode are shown correctly it's just about the intro log sequences when starting the game. I would assume that there is somewhere a script, which defines which resolutions are allowed at this point?

2. When loading a map for the first time the usual map screenshot is displayed correctly...but when loading a save game with the custom screenshot from the moment it was saved, then I just see a white wall again. Overlay loading graphics are displayed correct, it's just about the background screenshot.

3. Firing some guns (phaser rifle) cause an ugly dark impact effect, which was probably intended in the original game as a kind of flash effect. But for unknown reasons this effect isn't bright anymore... its black. Should be a shader problem and/or with the alpha texture, that creates this impact flash. But no idea where to find nor to fix this. Any idea?

Cheers :bye: ,



I feel as head of technical I should at least acknowledge your topic. Unfortunately I'm not going to be much help here, I will try and contact a few people who I think might be able to help you with this, I don't have any experience here so any suggestions I have would be based on pure guess work.

Hopefully someone with a little more experience in this area of the game will be in touch soon.

Web: http://last-outpost.net
E-Mail: technical@last-outpost.net

Earth's Elite Ambassador

Telex Ferra

Really interesting project! Do all three things happen when your mod is NOT installed?


Thanks, every help would be appreciated.

@Tellex Ferra
The first both issues with the intro videos and savegame level shots definitely referring to a costume resolution setting. I set the resolution via the config file manually to 1920x1080. Playing the game with standard given aspect and resolution settings works fine. So...as I said there must be a script where is written which resolution will be accepted for the intro video and for the savegame-loading level shots background. All the other the stuff like loadings screens and mission sequence work fine even on cotton resolution...ist just about these two points. If thats the case it should be easy to solve...but you need to know where to look. I tried to find it, but with no success.

The third issue with the black flash effect seems to be a general problem on modern systems. I tried clean installations on Windows 7, 8 and 10 64 bit and it appears also. The whole thing is a primitive form of lighting. Usually games of this period realized this with an alpha channel texture that is just overlaying the usual environment textures of walls, floors etc. to create ,,lighting". There must be also a shader somewhere, which one defines the blending and transparency characteristic of this texture. If I could find out which texture and/or shader is used to create the flash effect, I could maybe find a solution or at least a work around.


Telex Ferra

I dabbled a bit in the RPG-X source code, but I don't believe the SP source is available anywhere. Is it possible that whatever video player they used simply can't accept a resolution that large?



SP sourcecode is available on MODDB: http://www.moddb.com/games/star-trek-voyager-elite-force/downloads

The game uses bink video format. As I said: all videos sequences during the SP story mode are played. In these cases the engine just upscaled and stretched the videos to 1920x1080. The intro videos remained untouched and their native resolution was not changed. So in general the game is able to display videos on that resolution but obvioulsy intro videos and savegame levelshots are handled different. BTW: you can hear the intro videos but you can´t just see them. I think there must be a script entry somewhere, that gives restrictions to that points.



OK, I figured it out.

The issue of not showing videos/loading level shots is known from Quake 3 and goes back to costum resolution settings which are not supported by the games videoplayer. There is no solution.

The firing shadow glitch problably goes back to what seems to was intended as an anti cheat protection. The original stvoy.exe forces the engine to load the systems opengl32.dll and to ignor costum dlls from the games main directory. Curiously that affects  the singleplayer mode only, while holomatch mode does not have this restriction. Maybe it was tested but later removed from the multiplayer and forgotten for the singelplayer executable.

I was able to fix it by just renaming the stvoy.exe but indeed this renaming causes the shadow bug. I found two workarounds: 1. just deactivate (set to "0") the dynamic light setting in the config file. You will lose the environment flash (but actually not a big loss); 2. renaming the stvoy.exe specificly to Quake3.exe. Shadows and shaders will work fine then but unfortunatly this will result in unaccountable framerate break ins.

Thansk for all your thougths.


Telex Ferra

Glad you were able to figure it out. Sorry we weren't able to help  :(