Bugfix: Low FPS on High end ATI/AMD Video Cards.

Started by Martin Thompson, June 19, 2011, 12:58:21 pm

Previous topic - Next topic

Martin Thompson

June 19, 2011, 12:58:21 pm Last Edit: June 28, 2014, 05:17:25 pm by Telex Ferra
Alright people, this is a problem thats been nagging me for the past 2 years now, thanks to Grizz I solved it.

The problem is this. Since driver version 10 of Catalyst, Elite Force (and all other Q3 engine games) has been getting
a low framerate in alot of areas of alot of RPG-X maps. For example the FPS in the USS Dauntless Transporter room when
you stand on the padd and you look to the door has been aroudn 10 FPS for me since driver version 10.

I am running on a ATI HD4850X2, not exactly a low end device, so you can imagine that me getting 10 FPS in alot
of areas of alot of maps, is quite frustrating. A previous fix was to rename your .exe to quake3.exe. For some people
this works, for me, it didn't.


For all the people who are having the same issue and the renaming of the .exe didn't fix the issue, here is a fix:

You need to replace a .dll that handles OpenGL drawing, revert it back to a previous state. There are 2 ways to do this.

1: The hard way. Get some old drivers from the ATI site, and extract it yourself:

QuoteObtain the atioglxx.dll file from a previous version such as 10.4.
1. download the appropriate 10.4 install package (32 bit, 64 bit)
2. launch install application
3. install process. We only wanted to unpack the files.
4. open a command prompt (type "cmd" at the run box)
5. browse to folder containing atioglxx.dl_ (yes, that's an underscore). Mine was in this path:
C:ATISupport10-4_vista64_win7_64_dd_ccc_wdm_enuPackagesDrivers DisplayW76A_INFB_98282
5. expand the file by typing without the quotes (meh, or even with the quotes lol) "expand atioglxx.dl_ atioglxx.dll"
6. copy that newly extrapolated .dll to
a. 64 bit Windows -- c:windowssystem32 and c:windowssyswow64. I opted to rename my old ones to *.old but I don't know if that was necessary. Also, these old OpenGL games on my Vista 64 bit OS didn't start working correctly until the file was in the C:windowssyswow64 folder so I don't know the circumstances where it will look in the system32 folder.
b. 32 bit Windows -- C:windowssystem32
Copied from http://www.sysopt.com/forum/showthread.php?t=205619

2: The easy way. I already did the above steps with version 9.4 of the drivers. I used the 64 bit drivers so this file might not work for you if you are running 32 bits.

Download this file: http://www.mediafire.com/?9a6esl4wa6p9ch4
Copy the file to c:windowssystem32 and c:windowssyswow64 (overwrite when prompted)
OR place it in the same folder as your stvef.exe or whatever engine you are using (ioCow, ioEF, RPG-XEF).

I hope this works for you all, it did for me!


Klaw

June 19, 2011, 01:13:27 pm #1 Last Edit: December 31, 1969, 07:00:00 pm by Guest
Testing Now--- Cross your fingers

Martin Thompson

June 19, 2011, 01:22:34 pm #2 Last Edit: December 31, 1969, 07:00:00 pm by Guest
If this works for you Klaw, please stick this topic. Ill go over to ubergames and post it aswell. Might be helpfull for alot of people.


Veritas

June 19, 2011, 03:26:47 pm #3 Last Edit: December 31, 1969, 07:00:00 pm by Guest
You could also just rename the exe to quake3.exe.

Grizz

June 19, 2011, 04:00:45 pm #4 Last Edit: December 31, 1969, 07:00:00 pm by Guest
Works in most circumstances - but not some, sadly.

Martin Thompson

June 19, 2011, 04:04:29 pm #5 Last Edit: December 31, 1969, 07:00:00 pm by Guest
Quote from: "Veritas"You could also just rename the exe to quake3.exe.

Like i mentioned in my post, that did not work for me, this does.


mrfibbles

July 13, 2011, 03:31:31 pm #6 Last Edit: December 31, 1969, 07:00:00 pm by Guest
Old thread, but it fixed my problem. I just renamed the exe to quake3.

Also the link in the OP isn't working, it would be nice if we could grab both the 32 and 64 bit versions and put them up there to simplify things for people.
So, if anyone has the .dll, could you upload it and put up the link? Or if Martin could see what's wrong with his link...

Martin Thompson

July 14, 2011, 06:25:30 am #7 Last Edit: December 31, 1969, 07:00:00 pm by Guest
Sorry, it appears i made the file private, I'll change it now so it should be working again.

Anyway, i couldnt compile the dll myself, for some reason it crashed, so I had a friend do it.
If anyone can follow the steps to make a 32 bit dll go ahead, I'm unable to do that unfortunately.


Veritas

August 14, 2011, 12:44:55 pm #8 Last Edit: August 14, 2011, 01:52:23 pm by Veritas
Hey all, I just upgraded to a new GPU (Radeon 6950) and while it is incredible, it's also proving to be a headache for me as I am suffering from this bug, and none of the older OpenGL DLLs are compatible! They either give me a "load error 998" on startup, or simply crash RPG-X (any version, from vanilla to ioCow to ioEF to rpgxEF) with no warning at all. Any way to fix this?

Update: I was able to fix the issue in two ways. One, I could use Thilo's new ioEF-1.38, but because ioEF has massive parse issues, I chose to stick to ioCow. To use ioCow, I simply installed the oldest catalyst driver I could find using the same method posted here - version 3.5, courtesy of OldAPPs.com. Everything is working fine, though it did break my Steam overlay.

Update 2: The Steam Overlay remains borked, but the latest version which seems to work is Catalyst 8.7. I'd be happy to provide the DLL if anyone needs it.

Martin Thompson

August 17, 2011, 01:57:39 pm #9 Last Edit: December 31, 1969, 07:00:00 pm by Guest
Sure, anything that helps can be posted here.

Is that a 32 bits or 64 bits dll?


Veritas

August 17, 2011, 02:21:08 pm #10 Last Edit: December 31, 1969, 07:00:00 pm by Guest
It's from before x64 anything was common, so I'm gonna say x32.

Nuclear_Sunshine

April 03, 2012, 11:52:58 am #11 Last Edit: December 31, 1969, 07:00:00 pm by Guest
Thank you!
Just upgraded to a crossfire set of HD 6950's, I didn't have to replace any DLL's, only rename the .exe to quake 3, but this is the only place I've found with an answer!

Cheers!

Veritas

April 03, 2012, 01:33:55 pm #12 Last Edit: December 31, 1969, 07:00:00 pm by Guest
Glad you got it working! 6950 is my card of choice as well, though alas, I only have one.