The Last Outpost

<

A vSlider Image

>

<

A vSlider Image

>

<

A vSlider Image

>

<

A vSlider Image

>

<

A vSlider Image

>

<

A vSlider Image

>

<

A vSlider Image

>

<

A vSlider Image

>

Latest Announcements

Welcome, Guest. Please login or register.
Did you miss your activation email?
Pages: [1]

Author Topic: /r_gamma not doing anything  (Read 1687 times)

nopinky

  • Provisional Officer (G)
  • *
  • Offline Offline
  • Posts: 405
    • View Profile
/r_gamma not doing anything
« on: December 20, 2011, 09:31:48 am »

I have a strange issue in RPGX; whenever I use the /r_gamma command, it doesn't look any different on the map? Any ideas why this is happening?
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

Jenson

  • Member-in-Chief
  • *
  • Offline Offline
  • Posts: 5705
  • Former President of TLO (2010-2014)
    • View Profile
Re: /r_gamma not doing anything
« Reply #1 on: December 20, 2011, 09:37:41 am »

What variable are you using? The only variables that will change the gamma are decimal numbers, except for /r_gamma 1 which is full brightness.
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

nopinky

  • Provisional Officer (G)
  • *
  • Offline Offline
  • Posts: 405
    • View Profile
Re: /r_gamma not doing anything
« Reply #2 on: December 20, 2011, 09:41:05 am »

I tried everything. All the variables. 0.1, 0.2, 0.5, 0.7, everything. Nothing happened.
I'm running it in a 640x480 window, Low geo. detail, med texture detail, Default color depth. Any idea why this is happening?
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

Jenson

  • Member-in-Chief
  • *
  • Offline Offline
  • Posts: 5705
  • Former President of TLO (2010-2014)
    • View Profile
Re: /r_gamma not doing anything
« Reply #3 on: December 20, 2011, 09:49:52 am »

Quote from: "Jmusial"
I tried everything. All the variables. 0.1, 0.2, 0.5, 0.7, everything. Nothing happened.
I'm running it in a 640x480 window, Low geo. detail, med texture detail, Default color depth. Any idea why this is happening?

No, that's very odd.

You can adjust the brightness another way, though, by hitting escape -> configure -> video -> video additional -> brightness.
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

Veritas

  • Elder Statesperson
  • *
  • Offline Offline
  • Posts: 4673
    • View Profile
    • The Last Outpost
Re: /r_gamma not doing anything
« Reply #4 on: December 20, 2011, 09:54:22 am »

If you still can't configure your gamma that way, try running the command r_ignorehwgamma 1 and then restarting your game, then setting it.
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

nopinky

  • Provisional Officer (G)
  • *
  • Offline Offline
  • Posts: 405
    • View Profile
Re: /r_gamma not doing anything
« Reply #5 on: December 20, 2011, 09:55:00 am »

And what does that do?
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

Veritas

  • Elder Statesperson
  • *
  • Offline Offline
  • Posts: 4673
    • View Profile
    • The Last Outpost
Re: /r_gamma not doing anything
« Reply #6 on: December 20, 2011, 10:19:50 am »

It tells the game to ignore the brightness/gamma settings your display and graphics card prefer, and to instead make itself brighter using software rendering. It won't look quite as nice, but it will make things work correctly in almost all cases.
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

Klaw

  • Elder Statesperson
  • *
  • Offline Offline
  • Posts: 3524
    • View Profile
    • Klaw's Mapping Class
Re: /r_gamma not doing anything
« Reply #7 on: December 20, 2011, 10:38:59 am »

After alt tabbing, type /r_gamma 0 then r_gamma 1 - This works, and resets the brighteness back to normal :D
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

nopinky

  • Provisional Officer (G)
  • *
  • Offline Offline
  • Posts: 405
    • View Profile
Re: /r_gamma not doing anything
« Reply #8 on: January 02, 2012, 06:21:12 pm »

Ok, I think I found the problem. For some reason, the gamma only changes in fullscreen mode, not windowed mode. Is this the same for anyone else?
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

Bisqwit

  • Recruit (R)
  • *
  • Offline Offline
  • Posts: 20
    • View Profile
Re: /r_gamma not doing anything
« Reply #9 on: January 04, 2012, 07:50:15 am »

It works fine for me in windowed mode. However, it tends to leave the desktop gamma at wrong levels when I alt+tab away or quit the game, so I have to always go to ATI control panel and fix it.
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

Monroe

  • Officer (T)
  • *
  • Offline Offline
  • Posts: 256
    • View Profile
Re: /r_gamma not doing anything
« Reply #10 on: January 04, 2012, 10:45:44 am »

I get no gamma issues :p
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

Veritas

  • Elder Statesperson
  • *
  • Offline Offline
  • Posts: 4673
    • View Profile
    • The Last Outpost
Re: /r_gamma not doing anything
« Reply #11 on: January 05, 2012, 09:55:12 am »

Again, for windowed mode, try r_ignorehwgamma or other fixes like that. Your graphics card probably only knows how to set gamma for the whole screen at a time.
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged

nopinky

  • Provisional Officer (G)
  • *
  • Offline Offline
  • Posts: 405
    • View Profile
Re: /r_gamma not doing anything
« Reply #12 on: January 05, 2012, 04:12:37 pm »

Tried that, didn't work.
« Last Edit: December 31, 1969, 07:00:00 pm by Guest »
Logged
Pages: [1]